#author("2018-07-20T12:11:46+09:00","","")
#navi(../)
* Ubuntu18.04にDropboxクライアントをインストールしてみる [#ve9c483d]
Ubuntu用のDropboxクライアントをダウンロードして、dpkgコマンドでインストールをしようとしたところ、~
依存関連のエラーが発生したので、このエラーの対処方法を以下に記します。~

#contents
#htmlinsertpcsp(linux_ads_top.html,linux-sp.html)

* 関連URL [#y0239980]
-DropboxクライアントダウンロードURL~
https://www.dropbox.com/ja/install-linux

* ダウンロードしたDropboxクライアントについて [#b0753f6e]
以下のURLからUbutnu 64bit のDropboxクライアントをダウンロードしました。~
https://www.dropbox.com/ja/install-linux
#ref(01.png)

* ダウンロードしたDropboxクライアントのインストール [#t49e47fd]
ダウンロードしたdebパッケージを端末からインストールしました。~
実行したコマンドのは以下の通りです。

ダウンロードしたDropboxのdebパッケージをdpkgコマンドを使ってインストールしましたが、エラーが発生しました。
 sudo dpkg -i dropbox_2015.10.28_amd64.deb

''実際のコマンド実行時の出力です。''
+dpkgコマンドでDropboxクライアントのdebパッケージをインストール。
 $ sudo dpkg -i dropbox_2015.10.28_amd64.deb 
 以前に未選択のパッケージ dropbox を選択しています。
 (データベースを読み込んでいます ... 現在 178278 個のファイルとディレクトリがインストールされています。)
 dropbox_2015.10.28_amd64.deb を展開する準備をしています ...
 dropbox (2015.10.28) を展開しています...
 dpkg: 依存関係の問題により dropbox の設定ができません:
  dropbox は以下に依存 (depends) します: python-gtk2 (>= 2.12) ...しかし:
   パッケージ python-gtk2 はまだインストールされていません。
  dropbox は以下に依存 (depends) します: libpango1.0-0 (>= 1.20.1) ...しかし:
   パッケージ libpango1.0-0 はまだインストールされていません。
 
 dpkg: パッケージ dropbox の処理中にエラーが発生しました (--install):
  依存関係の問題 - 設定を見送ります
 desktop-file-utils (0.23-1ubuntu3.18.04.1) のトリガを処理しています ...
 gnome-menus (3.13.3-11ubuntu1) のトリガを処理しています ...
 mime-support (3.60ubuntu1) のトリガを処理しています ...
 hicolor-icon-theme (0.17-2) のトリガを処理しています ...
 man-db (2.8.3-2) のトリガを処理しています ...
 処理中にエラーが発生しました:
  dropbox
+ 「libpango1.0-0 がインストールされていない」とメッセージ出力があったのでlibpango1.0-0をインストール
 $ sudo apt install libpango1.0-0
 パッケージリストを読み込んでいます... 完了
 依存関係ツリーを作成しています                
 状態情報を読み取っています... 完了
 これらを直すためには 'apt --fix-broken install' を実行する必要があるかもしれません。
 以下のパッケージには満たせない依存関係があります:
  dropbox : 依存: python-gtk2 (>= 2.12) しかし、インストールされようとしていません
  libpango1.0-0 : 依存: libpangox-1.0-0 (>= 0.0.2-2~) しかし、インストールされようとしていません
 E: 未解決の依存関係です。'apt --fix-broken install' を実行してみてください (または解法を明示してください)。
+依存関係エラー発生したので、メッセージに従い apt --fix-broken install を実行~
Y/nが表示されるので、Yを入力しEnterキーを押します。
 $ sudo apt --fix-broken install
 パッケージリストを読み込んでいます... 完了
 依存関係ツリーを作成しています                
 状態情報を読み取っています... 完了
 依存関係を解決しています ... 完了
 以下の追加パッケージがインストールされます:
   libpango1.0-0 libpangox-1.0-0 python-cairo python-gobject-2 python-gtk2
 提案パッケージ:
   python-gobject-2-dbg python-gtk2-doc
 以下のパッケージが新たにインストールされます:
   libpango1.0-0 libpangox-1.0-0 python-cairo python-gobject-2 python-gtk2
 アップグレード: 0 個、新規インストール: 5 個、削除: 0 個、保留: 0 個。
 1 個のパッケージが完全にインストールまたは削除されていません。
 901 kB のアーカイブを取得する必要があります。
 この操作後に追加で 4,805 kB のディスク容量が消費されます。
 続行しますか? [Y/n] 

上記の手順により、UbuntuにDropboxクライアントをインストールできると思います。

インストール後、しばらくすると以下の画面が表示されました。~
''Start Dropbox''ボタンを押してメッセージに従ってセットアップすれば完了です。
#ref(02.png)

以上、Ubuntu18.04にDropboxクライアントをインストールしたときの備忘録です。

#htmlinsertpcsp(linux_ads_btm.html,linux-sp.html)


トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS