このエントリーをはてなブックマークに追加


Debian9にVivaldiをインストール

Debian9にVivaldiをインストールした時にパッケージ足らずでインストールが中断しました。
その後、必要なパッケージをインストールし無事、Vivaldiをインストールすることができました。
以下に操作手順を記します。


スポンサーリンク

VivalidのDEBパッケージをダウンロード

以下のURLからDebian系のパッケージである、DEBをダウンロードします。
https://vivaldi.com/download/

端末からインストール

端末からVivaldiをインストールしました。
尚、Debianでsudoを使えるように設定済ため、sudoコマンドを利用しています。

参考記事

以下、dpkgコマンドによる出力です。

sakura@debian:~/Downloads$ sudo dpkg -i vivaldi-stable_1.10.867.48-1_amd64.deb 
以前に未選択のパッケージ vivaldi-stable を選択しています。
(データベースを読み込んでいます ... 現在 157709 個のファイルとディレクトリがインストールされています。)
vivaldi-stable_1.10.867.48-1_amd64.deb を展開する準備をしています ...
vivaldi-stable (1.10.867.48-1) を展開しています...
dpkg: 依存関係の問題により vivaldi-stable の設定ができません:
 vivaldi-stable は以下に依存 (depends) します: libappindicator1 ...しかし:
  パッケージ libappindicator1 はまだインストールされていません。
dpkg: パッケージ vivaldi-stable の処理中にエラーが発生しました (--install):
 依存関係の問題 - 設定を見送ります
menu (2.1.47+b1) のトリガを処理しています ...
desktop-file-utils (0.23-1) のトリガを処理しています ...
mime-support (3.60) のトリガを処理しています ...
処理中にエラーが発生しました:
 vivaldi-stable

上記のエラーメッセージにより、libappindicator1 パッケージが足りないと言われたのでインストールします。

sakura@debian:~/Downloads$ sudo apt install libappindicator1
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
これらを直すためには 'apt --fix-broken install' を実行する必要があるかもしれません。
以下のパッケージには満たせない依存関係があります:
 libappindicator1 : 依存: libdbusmenu-glib4 (>= 0.4.2) しかし、インストールされ ようとしていません
                    依存: libdbusmenu-gtk4 (>= 0.4.2) しかし、インストールされようとしていません
                    依存: libindicator7 (>= 0.4.90) しかし、インストールされようとしていません
E: 未解決の依存関係です。'apt --fix-broken install' を実行してみてください (または解法を明示してください)。

依存関係が未解決だと言われたので、メッセージの通り、apt --fix-broken install を実行します。

sakura@debian:~/Downloads$ sudo apt --fix-broken install
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
依存関係を解決しています ... 完了
以下の追加パッケージがインストールされます:
  libappindicator1 libdbusmenu-glib4 libdbusmenu-gtk4 libindicator7
以下のパッケージが新たにインストールされます:
  libappindicator1 libdbusmenu-glib4 libdbusmenu-gtk4 libindicator7
アップグレード: 0 個、新規インストール: 4 個、削除: 0 個、保留: 0 個。
1 個のパッケージが完全にインストールまたは削除されていません。
300 kB のアーカイブを取得する必要があります。
この操作後に追加で 570 kB のディスク容量が消費されます。
続行しますか? [Y/n] 
<snip>
update-alternatives: /usr/bin/vivaldi (vivaldi) を提供するために自動モードで /usr/bin/vivaldi-stable を使います
libc-bin (2.24-11+deb9u1) のトリガを処理しています ...
menu (2.1.47+b1) のトリガを処理しています ...
sakura@debian:~/Downloads$

無事インストールが完了しました。

まとめると

  1. 端末を起動
  2. ダウンロードしたディレクトリにcd
  3. 必要に応じてrootにsu
  4. dpkg -i で vivaldiのDEBパッケージをインストール
  5. 足りないパッケージ、今回は libappindicator1 をaptコマンドでインストール
  6. 依存関係が未解決だと言われ、解法のコマンドを実行 apt --fix-broken install

上記の操作で無事メニューにも表示されました。

01.png

以上、Debian9にVivaldiをインストールした時の備忘録でした。


スポンサーリンク


添付ファイル: file01.png 57件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2017-08-09 (水) 23:36:47 (435d)